You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2019-11-11 10:43:57

MOSH
Member
Registered: 2019-11-11

Cannot create Catalina OS images - Systems shutdown during the process

Hello there,
My name is Mosh Werner and I've been working with the great product for years now...
I had updated the deployment servers a few times already and currently I'm using the latest version (1.7.8)
My Mac Server OS version is 10.7.5.
Everything worked fine until 10.14 macOS, I was able to create images flawlessly.
Now, with the Catalina OS (10.15) while in the process, the macOS restarts and I see a system message saying that the computer shut down unexpectedly.
The images size is smaller, around 7.7GB for the 10.15 image, while the 10.14 image is 18.2GB.
I tried loading the 10.15 image and the system did not run, it does seems that the 10.15image is corrupted and I cannot save any more 10.15 images...

Did anyone experience this issue? what can be done?
I have no idea what to do.

I have tried to save my Catalina images from 2 different macbooks, a mac book pro 2018 and a mac book pro from 2012.

Please help.

Regards,

MOSH

Offline

#2 2019-11-25 14:58:40

jeremyd
Member
Registered: 2017-07-21

Re: Cannot create Catalina OS images - Systems shutdown during the process

Apple changed the way the OS image is partitioned on 10.15. It now has a ready only system partition and a "data" partition. DeployStudio doesn't know how the two are connected using volume groups so it only captures one or the other.

In order to capture an image for Catalina you would now have to use the built in apple tool called ASR. I installed MacOS 10.15.1 on an external USB drive and just boot the mac to that. Then use ASR to create the image.

Once you have a working image you can then use ASR to restore it back back to the disk of another mac.

You can actually script the capture and restore to a .sh file and use deploystudio to run the scripts and then any post flight stuff you do after imaging. You can't build a boot disk using deploystudio anymore though. You need to just install macOS to an external USB disk and boot to the OS from that. You can run Deploystudio from that disk once booted.

Offline

Board footer

Powered by FluxBB