You are not logged in.


[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2019-05-20 11:28:05

Registered: 2009-11-11

Help DS Replica server not syncing anymore

I am running DeployStudio Server 1.7.8 on the Master and Replica servers. Both servers are running under High Sierra 10.13.6.

I did originally have the Replica server successfully syncing to the Master server. I had been monitoring via the DeployStudio preference pane which showed a green blob and that the most recent sync had occurred the previous night and run for just seconds. This short duration made sense as the replica was doing little or nothing and I typically on a given day made minimal changes to the master.

However closer inspection today after I uploaded a new image for Mojave 10.14.5 to the master showed the new image was not there on the replica after a sync and in fact no real syncing had occurred since March 13th.

I have tried manually triggered a sync via the preference pane and by manually running the script. In both cases it is obviously not working as nothing is being synced despite the false impression given by the preference pane.

In Console in System.log the only entry that shows up when filtering for deploystudio is as follows (and this is true for both the Master and Replica servers)

May 20 10:52:04 it-admin-mac DeployStudioServer[2269]: objc[2269]: __weak variable at 0x7fdf4c61ba70 holds 0x7fdf4c610002 instead of 0x7fdf4c619770. This is probably incorrect use of objc_storeWeak() and objc_loadWeak(). Break on objc_weak_error to debug.

If I run the curl command from the script with the redirection of output to /dev/null removed (so it can be seen) I get the following message.


Does anybody have any ideas how to fix this? I have tried uninstalling and reinstalling on the Replica server but not the Master.

My best guess in view of the date it stopped working is that possibly an Apple security update has broken something. The mention of bplist00? might suggest a plist file has changed from XML to binary and a command is now choking on it. However I have no idea which and where this plist might be if this is the case.

The Replica server is able to reach the Master, I have tested this via the web browser on the Replica server.

The curl command clearly talks to the local i.e. Replica server and is then supposed to trigger the DeployStudio server in to doing a sync. Sync the script is merely acting as a trigger and is not doing the actual work does anyone know where the real script i.e. the script doing the actual syncing is located? I could then examine it and possibly add additional debugging to it.


#2 2019-05-22 11:33:05

Registered: 2009-11-11

Re: Help DS Replica server not syncing anymore

Turned out to be my fault.

In order to provide a common NetBoot set and USB boot set for multiple sites I have used the same host name at multiple sites although each site has a different IP address and different fully qualified domain name.

In order for the NetBoot and USB boot to use the same name anywhere I used the Bonjour name. This is fine as far as that is concerned. A client will NetBoot or run the DS Runtime and access its local DS Server via the Bonjour address. What I had got wrong was I was using the Bonjour name for the AFP connection. This again works for the local DS Runtime but breaks the Master/Replica syncing since it turns out the syncing also occurs over AFP.

As a result the replica was trying to sync to itself.

I fixed things by still using the Bonjour name for the DS Runtime communications to the local DS server but then DS server then tells the DS Runtime client to use the FQDN for AFP.

Problem sorted.


Board footer

Powered by FluxBB