You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-11-09 13:19:39

oleksiak
Member
Registered: 2012-08-21

DS 1.7.8 and 10.13.x NetBoot builds multiple issues

I wanted to report some problems I observe with netboot images created using DS 1.7.8 from macOS 10.13 and 10.13.1 systems:
1. Boot time is over 6 times longer than 10.11.x or 10.12.x builds (on MacPro6,1 it takes now 240 seconds vs 37 seconds with NFS, HTTP is even more slower; netboot image was created on the same machine; hosted on 10.12.6 macOS Server.app)
2. /usr/sbin/system_profiler binary is missing.
3. VNC access is not working, again (port is closed, no ARD/screen sharing processes running).

Last edited by oleksiak (2017-11-09 13:53:39)

Offline

#2 2017-11-09 21:11:58

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

I can only confirm 1 and 3, and I do not use system_profiler.
Maybe use ioreg to find what you are looking for?

Offline

#3 2017-11-13 09:27:20

oleksiak
Member
Registered: 2012-08-21

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

Yes, fortunately I can do without system_profiler.

Offline

#4 2017-12-13 13:55:49

kbotnen
Member
Registered: 2016-01-19

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

Its a problem that /usr/sbin/system_profiler as we use it in our workflow scripts :/

to retrieve the serialnumber of the machine that is imaged. But guess there are other ways to achieve that.

Offline

#5 2017-12-13 14:00:29

oleksiak
Member
Registered: 2012-08-21

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

Check ds_example.sh script. You can find many environmental variables there, including DS_SERIAL_NUMBER you are interested in.

Offline

#6 2017-12-13 14:04:17

kbotnen
Member
Registered: 2016-01-19

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

Hi,

I will check that. Thanks.

It will also work with: ioreg -c IOPlatformExpertDevice -d 2 | awk -F\" '/IOPlatformSerialNumber/{print $(NF-1)}'

for reference.

Using environment variables are probably the best way to do it :)

Offline

#7 2017-12-13 21:22:46

ebonweaver
Member
Registered: 2015-06-09

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

Thus far making a netboot set from 10.13 flat does not work with the DS assistant.  As soon at it tries to process the new recovery partition format it errors out.  Impression is we're waiting for 10.13 recovery support to be added into DS.

Offline

#8 2017-12-13 21:40:24

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: DS 1.7.8 and 10.13.x NetBoot builds multiple issues

I made a netboot set using a mounted image of 10.13.0 created by AutoDMG as source.
Cannot remember if that was afps or hfs. I think both work on DS 1.7.8

Last edited by mjsanders (2017-12-13 21:40:53)

Offline

Board footer

Powered by FluxBB