You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-10-19 16:46:53

COEBS
Member
Registered: 2017-09-06

Inappropriate Repository Error

I'm having trouble resolving the Inappropriate Repository Error. I'm using Deploy Studio build v1.7.8, Mac OS Server version 5.4 (Build 17S1207) and Mac OS 10.13 (Build 17A405). My login is COE. My images are located on my desktop in a folder called Images, which is shared read/write for everyone. I've accepted defaults for everything on the DeployStudio Server setup. On the netboot setup I've tried both HPPT and NFS, making sure it was the only netboot set in the Library/NetBoot/NetBootSP0 folder. I've read everything I can find, but either it doesn't help, or I'm missing something in the post. I've tried to find a way to set the path in the Server setup to something other than /Users/coe/Desktop/Images but I can't find a way to put anything else in there, such as an IP address or the local machine name so that when the computers boots to the DeployServer it can find it, in case that's the problem. It took me forever to get it to even create netboot sets and then to get the MacBook to even see it when it booted (I had used this successfully until about 6-8 months ago, when the Mac builds changed). I should also probably mention that I'm really more of a PC person, so my Mac knowledge isn't what I would like, so please keep that in mind if you are able to provide any direction--I need basics. Any help would be greatly appreciated.

Offline

#2 2017-10-19 18:33:00

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: Inappropriate Repository Error

If you are using a server, and netbooting to the server from your target machines, the DeployStudio server configuration must specify the repository as  "a network sharepoint" path.

One of the configuration windows is dedicated specifically to designating whether the server will use "a local folder" or "a network sharepoint".
Select "a network sharepoint".

In the next window, see the examples under the URL: field.
The URL will typically be like afp://yourservers.name/Images, or smb://yourserver.name/Images
You can substitute the IP address for yourserver.name if you suspect a DNS issue.

I'd recommend going into Server.app and unsharing your repository, moving your repository to /Users/Shared then resharing your repository.
It's counter intuitive, and possibly problematic to have the repository in your home folder.

Last edited by Meat (2017-10-19 18:36:13)

Offline

#3 2017-10-20 23:41:03

COEBS
Member
Registered: 2017-09-06

Re: Inappropriate Repository Error

Thanks so much for you reply. Unfortunately, still not working. I deleted the Images folder and created a new one at Users/Shared/Images and shared that in file sharing as read/write for everyone. I changed to network sharepoint from local folder, and had trouble getting it to accept the path, but it finally did with nfs://147.97.133.62/Users/Shared/Images. It would not accept either smb or afp , and I did have to use the IP address, so apparently a DNS issue involved as well. However, now even though the MacBook will see the DeployStudio server when you boot, when you pick it, it just boots to the desktop like you booted normally. This is where I was when it quit working several months ago with all my previous versions of DeployStudio and Mac OS Server.

Here's how I set it up: For the server name, it says https://147.97.133.62.local:60443 - I replaced the name of the computer, which is COEdpMac with the IP address and left everything else the same. I entered the username and password, selected create a Master, then checked network sharepoint. Here I put the address mentioned above. If I used either afp, smb or cifs, it said "Repository access error. The defined repository cannot be mounted. Check, your settings." I accepted defaults for everything else. On the netboot I replaced the machine name with the IP address, and I tried both HTTP and NFS, but accepting defaults there as well.

Is there anything I need to change in the Mac Server OS setup? I tried putting in the IP address there, but that didn't seem to work. The only documentation I can find is not for the current version, but I tried to follow as best that I could. Any other ideas? I really need to be able to fix this. I was so sure it would work when I was able to put in the network sharepoint address.

Also, you mention going into server app and changing the share--apparently the file sharing is not an option in the latest server release--I had to share in File Sharing in System Preferences.

Last edited by COEBS (2017-10-23 16:39:11)

Offline

#4 2017-10-22 12:54:52

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: Inappropriate Repository Error

I see a few URL issues in your post. Check these, and please be consistant: everywhere the same (IP, .local or FQDN)

The server,
in system preferences you see the url that the server likes best. Depending on what you entered at the setup wizard that can be
https://147.7.133.62:60443 (no .local in here if you use IP number) OR use https://COEdpMac.local:60443 (local host name)
If you have dns, this can be https://your-fully.qualified.domain.name:60443
On the Runtime client: please use the same url as the server prefers (although both could work at the same time, please use the same as the preference pane shows)
If needed, remake the netboot image, using the correct url to connect to make it connect automatically.

The repository:
NFS is special, you have to specify the full path of the shared folder. For AFP and SMB you have to specify only the name of the shared folder.
If nfs://147.7.133.62/Users/Shared/Images works, the url for afp or smb should be:
afp://147.7.133.62/Images and smb://147.7.133.62/Images (or smb://COEdpMac.local/Images, or  smb://your-fully.qualified.domain.name/Images)
(Provided both AFP and SMB are enabled for this sharepoint)
I use a macOS server, and I have best results with afp and smb, nfs has given me some issues in the past.

Check from a mac on the network to mount the repository url manually as test.

Offline

#5 2017-10-23 16:28:16

COEBS
Member
Registered: 2017-09-06

Re: Inappropriate Repository Error

The same problem continues. I could always mount the folder manually, and still can--I just checked.  It sees the DeployStudio Server when holding option, but when you select it to boot to, it just boots to the desktop. I notice that the little spinning world is not there like it should be. Here's my setup in greater detail--maybe there is something that got changed that should not have and I may have just looked at it for so long that I'm overlooking something
DeployStudio Assistant Server Setup
Welcome Screen -
Sever Connection - I've entered https://147.97.133.62:60443, along with the user name and password
Server Role - Master
Repository Type - A Network SharePoint
Repository Setting - url is  smb://147.97.133.62/Images (I don't know why smb started working--the best I can tell, nothing changed except I moved the Images folder to the Macintosh HD folder - it was already shared at the first location) entered user and password. Nothing in advanced parameters.
Email notifications - skipped
Network Security - com.deploystudio.server Interface is Any, port is 60443. Other security is unchecked.
User Groups - skipped
Multicast Settings - All defaults, I believe Default interface is Ethernet, multicast TTL is 3, Address is 224.77.2.77 and first stream port is 7800
Database options - Hardware Serial Number which is default

For the NetBoot Set
Welcome and Service Information Screens - default
General Settings - Source base system is Current Boot volume
System Name -  is DSR-10130. Unique Identifier is 1130, Protocol NFS (I did hear somewhere that it had to be HTTPS, but even trying that didn't help, so I've left it at this) Language is Current and Network time server is time.apple.com
Service Discovery - Both are https://147.97.133.62:60443 (It was coedpmac.local:60443
Authentication is username and password, - rest left blank
Options - left as default, with Disable Wireless support check, rest unchecked.
Destination is /Library/NetBoot/NetBootSP0, which is correct and default.

On my MacOS Server, the server name is coedpmac - I don't think I need to change the name to the IP address, here.

I'm not sure what else I can try. Ever since I switched to the Network sharepoint, it just boots to the desktop after selecting the DeployStudio server after holding option.

I sincerely appreciate that you are trying to help.

Last edited by COEBS (2017-10-23 16:37:37)

Offline

#6 2017-10-23 22:23:16

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: Inappropriate Repository Error

For the netboot set, I would change the destination to the desktop of the machine you are creating the set on.
There were issues, many moons ago, when creating the netboot set and automatically sending it to the NetBootSP0 folder on the server.
Ever since then, I've always created the netboot set on the desktop, then manually copying it to the server's NetBootSP0 folder.

Otherwise, I'm not seeing anything too odd...

Offline

#7 2017-10-27 14:31:56

COEBS
Member
Registered: 2017-09-06

Re: Inappropriate Repository Error

I have finally solved this. It would not work with the Images folder in the /users/shared folder. I had tried putting it at the root level before--but I contributed to my own issues when I called it DSImages rather than just Images, as when I entered the name in the repository path, I wasn't matching the case for the "I", not realizing that it was going to be case sensitive. I also had to use the IP address in the repository path, although I was able to use the server name everywhere else. I also used afp--not sure if it would have worked with smb or not. Definitely had to use the network sharepoint type for the repository, even though it is in a local folder--not sure I understand that, but I've been working on this off and on for months--Soooooo glad it's finally working. Thank you to everyone who replied--I might never have gotten it to work if Meat hadn't pointed out I had to use the Network SharePoint.

Last edited by COEBS (2017-10-27 14:33:23)

Offline

#8 2017-10-28 00:38:32

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: Inappropriate Repository Error

Regarding server path vs. local path, I believe it is typical that the clients connect to the server, the server does not connect to the client.
Think of it in terms of where the actions are taking place. The target machine launches the runtime (from the netboot image) and the runtime has to connect to the repository from there.
The netboot image is essentially just a standalone OS downloaded from the server. The target machine is establishing the connections to the server.

Conversely, you might be using an external hard drive to boot target machines, and image from, in a one-off scenario. In that case, you "could" point to a network repository, but you'll probably have the image stored locally (in case network issues...) and so, a local path would be used in that case.

Yeah. There's probably a much better description somewhere... :P

Last edited by Meat (2017-10-28 00:42:51)

Offline

Board footer

Powered by FluxBB