You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-10-07 23:29:10

terryj
Member
Registered: 2009-05-08

DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

New issue: updating my DS Server from os x 10.95/ 1.7.8 to El Capitan 11.06 /1.78 and after updating the server following the steps as listed in this
Apple Article here: https://support.apple.com/en-us/HT207034
and now after reboot, I cannot connect to the Deploy Studio Server.
I went back through the setup assistant and I can't get the Deploy Studio Server to recreate,
keeps giving me the "address of server:60443" is unreachable error.

I've tried uninstalling, re-installing, several reboots and the error persists. OS X Server version is at 5.15, also if that helps.
Just trying to move the DS server from Mavericks to Sierra is what started all of this.

Any help trying to figure out where to start to troubleshoot would be helpful...


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#2 2017-10-09 17:44:12

terryj
Member
Registered: 2009-05-08

Re: DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

Tried uninstalling and reinstalling. Have also updated my OS X Server version from v.5.015 to V.5.2, issue still persists.
I have also tried the "Unshare, reshare, run assistant for DS Server setup" fix posted here, <http://www.deploystudio.com/Forums/viewtopic.php?id=7293 >still the issue persists...


here are my Console Logs when I try and run the Setup Assistant:

10/9/17 11:02:09.941 AM    DeployStudio Assistant[3110]    DeployStudio Assistant
10/9/17 11:02:09.942 AM    DeployStudio Assistant[3110]    DSCore.framework version 1.7.8 (b170908), Copyright 2017 The DeployStudio Team.
10/9/17 11:02:09.943 AM    DeployStudio Assistant[3110]    MAC address: 40:6c:8f:2a:e2:29
10/9/17 11:02:09.959 AM    DeployStudio Assistant[3110]    Network address: 10.220.1.99 (dsserver.yukonps.com)
10/9/17 11:02:09.990 AM    DeployStudio Assistant[3110]    Network interface speed: AUTOSELECT (1000BASET <FULL-DUPLEX,FLOW-CONTROL>)
10/9/17 11:02:10.032 AM    DeployStudio Assistant[3110]    Operating System: Mac OS X Version 10.11.6 (Build 15G1611)
10/9/17 11:02:10.032 AM    DeployStudio Assistant[3110]    Date: 17/10/09 11:02:10
10/9/17 11:02:10.032 AM    DeployStudio Assistant[3110]    ====================================================================================================
10/9/17 11:02:12.267 AM    DeployStudio Assistant[3110]    "/Applications/Utilities/DeployStudio Admin.app/Contents/sbin/DeployStudioServerEnabler" -start 2>&1
10/9/17 11:02:14.380 AM    com.apple.xpc.launchd[1]    (com.deploystudio.server) This service is defined to be constantly running and is inherently inefficient.
10/9/17 11:02:39.910 AM    secd[517]     securityd_xpc_dictionary_handler DeployStudio Ass[3110] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:02:39.910 AM    DeployStudio Assistant[3110]     SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:02:43.757 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.760 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.762 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.765 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.767 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.770 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.772 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.774 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.777 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.779 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.781 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.783 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.786 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.788 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.790 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.793 AM    DeployStudio Assistant[3110]    Could not connect to the server. (-1004), retrying command in 5s...
10/9/17 11:02:43.795 AM    DeployStudio Assistant[3110]    [DSServerClientController valueForURI:error:] error: Could not connect to the server. (-1004)
10/9/17 11:02:58.639 AM    secd[517]     securityd_xpc_dictionary_handler DeployStudio Ass[3110] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:02:58.639 AM    DeployStudio Assistant[3110]     SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:02:58.759 AM    secd[517]     securityd_xpc_dictionary_handler DeployStudio Ass[3110] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:02:58.759 AM    DeployStudio Assistant[3110]     SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
10/9/17 11:03:00.769 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:02.772 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:04.774 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:06.777 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:08.779 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:10.781 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:12.784 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:14.786 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:16.789 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:18.791 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:20.794 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:22.795 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:24.798 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:26.799 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:28.802 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:30.804 AM    DeployStudio Assistant[3110]    The request timed out. (-1001), retrying command in 5s...
10/9/17 11:03:32.806 AM    DeployStudio Assistant[3110]    [DSServerClientController valueForURI:error:] error: The request timed out. (-1001)


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#3 2017-10-09 17:58:24

terryj
Member
Registered: 2009-05-08

Re: DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

If I have to guess looking at my logs Securityd is having an issue with an item in the Keychain?
the line "NSDescription=client has neither application-identifier nor keychain-access-groups entitlements" is what makes me think that...


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#4 2017-10-09 19:07:06

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

I would recommend uninstall Deploy Studio from the server, delete the preference files (/Library/Preferences/), install Sierra, update the Server.app, then unshare/reshare the repository, install Deploy Studio and configure.

Not sure what the purpose of going to 10.11.x was if your goal is to go to Sierra (10.12.x).
All three of my Deploy Studio servers are running 10.12.6 without difficulty (though I configured them all as masters...)

Offline

#5 2017-10-09 19:24:17

terryj
Member
Registered: 2009-05-08

Re: DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

Meat,
I was following the instructions Apple set about here:

https://support.apple.com/en-us/HT207034

As my Deploy Studio Server was originally ( as posted in the first posting):
os x 10.95/ 1.7.8  ( OS X Server Mavericks 10.9.5 / Server 3.22 / Deploy Studio Server 1.7.8)

this was working all year thus far without fail.

Migrating to Sierra 10.12.06 / Server 5.3 / DS Server 1.7.8 is the end goal.....


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#6 2017-10-10 22:27:28

terryj
Member
Registered: 2009-05-08

Re: DS 1.7.8, OS X 10.11.06, address of server:60443 unreachable error

Steps it finally took to got it to be fixed:

Ran Uninstaller of DS 1.78.
then
Removed all instances of Deploy Studio from the following places:

remove the apps from /Applications/Utilities/
delete the plist from /Library/LaunchDaemons/
remove the plist from /Library/Preferences/
remove the folder from /Library/Application Support/
remove both plists from ~/Library/Preferences/

then using Find Any File (with Show Invisibles turned on), found and removed all instances of "com.deploystudio" and "deploy studio" I found.

Next went into Keychain Access and removed all instances of "com.deploystudio"

Rebooted into Recovery Drive
Ran Disk Utility
made sure SIP was disabled ( I also was having the Deploy Studio Pref Pane crash every other time it was launched)
Rebooted
then went into Server.app and did the "unshare the repo, quit Files Sharing, close the Server.app, wait a minute, then reopen the Server.app, and Turn on File Sharing and recreate the repo" notorious fix
then installed DS 1.7.8

Success!
the Pref Pane did not Crash, and the Setup Assistant created everything smooth. I did lose my Scripts ( not my Packages or my Masters, as I moved them off of the Repro before recreating it),
but I had those backed up in a .zip archive in my dropbox, so I restored them from there.

One last piece, yes you will need to re-create your .nbi files, as the path comes up unreachable when booting from them after this, but for my initial test, I just manually entered in the server credentials
and it worked.


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

Board footer

Powered by FluxBB