You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-02-24 13:49:15

laeeqhumam
Member
Registered: 2013-07-25

New MBP With Touch Bar does not boot after workflow runs

Hi Guys,

This is happening only with the new devices that have been bought. Workflow does not have OS restore but just few packages and scripts. It has been tested and they are ok. But after it runs and Mac reboots, it shows the folder with question mark. Probably its not able to find the boot drive / folder.
But the same workflow works for OLDER hardwares.

I checked the details and found following. This Bless command wont work because for new Macs, the device is no more /dev/disk0 so that bless is forcing to wrong partition. Solution was to stop the workflow after it finishes by clicking on SELECT OTHER WORKFLOW. And then launch Terminal and bless to correct the bless boot partition.
It works :) BUT I wanna do it inside DS so that I dont have to do this.

Is anyone else facing this?
Or can someone suggest where to change this bless command.


2017-02-24 12:55:28.761 DeployStudio Runtime.bin[336:8396] /usr/sbin/bless --device /dev/disk0 --setBoot --verbose 2>&1
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] EFI found at IODeviceTree:/efi
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] found ioreg "FirmwareFeaturesMask"; featureMaskValue=0xFC03FF3F
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] found ioreg "FirmwareFeatures"; featureFlagsValue=0xFC03F53E
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] isPreBootEnvironmentUEFIWindowsBootCapable=1
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] given BSD is not a DVD disc medium
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] isDVDWithElToritoWithUEFIBootableOS=0
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] Checking if disk is complex (if it is associated with booter partitions)
2017-02-24 12:55:28.845 DeployStudio Runtime.bin[336:8396] Preferred system partition found: disk0s1
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] Returning booter information dictionary:
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] <CFBasicHash 0x7fbffb40dc70 [0x10ed14d80]>{type = mutable dict, count = 3,
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] entries =>
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396]     0 : <CFString 0x10e6bd990 [0x10ed14d80]>{contents = "System Partitions"} = (
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396]     disk0s1
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] )
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396]     1 : <CFString 0x10e6be170 [0x10ed14d80]>{contents = "Data Partitions"} = (
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396]     disk0
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] )
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396]     2 : <CFString 0x10e6be190 [0x10ed14d80]>{contents = "Auxiliary Partitions"} = (
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] )
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] }
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] IOMedia disk0 does not have a partition UUID
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] IOMedia disk0 does not have a Volume UUID
2017-02-24 12:55:28.846 DeployStudio Runtime.bin[336:8396] IOMedia disk0 has path IODeviceTree:/PCI0@0/RP17@1B/SSD0@0/IONVMeController/IONVMeBlockStorageDevice@1/@1:0


Bestestestestttt Regards,
James H

Offline

Board footer

Powered by FluxBB