You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2016-12-04 09:36:30

Vij Na
Member
Registered: 2014-11-25

Zero-touch Imaging

My objective is to have a zero touch imaging for the mac laptops which have just been purchased.
My setup
Deploy studio 1.7.5 and my workflow includes an alert for 3 sec. then the restore then configure for the computer name and lastly a quick add package (postponed install). All steps are in Automate mode so there is no human intervention when a new mac laptop is connected.

My process
1. Create a computer list.
2. Import the computer serial numbers and assign a name and local hostname and select the default image workflow (Reset box ticked so this happens only once)
3. Take a newly purchased laptops out of box - connect to network - netboot (10.12.1) and the deploy studio runtime launches with the default workflow and imaging is done based on the serial number of the Mac laptop.

What actually happens is the net boot is fine - Runtime is launched and the Terminal app launches with a window.
Quit from Terminal the computer reboots. This happen three or four times before the computer finally picks up the default image and all is fine.

Why does the deploy studio runtime launch terminal 3 to 4 times initially. Any thoughts.

thanks

Please note at times the process works fine (without the terminal showing up). However I have not been able to correlate or pin-point a cause.

Update:
Completed a batch of 20 Macbook Air laptops. 14 of them imaged well the first time (without the terminal app coming up) Checking the logs after a successful image and one which the terminal comes up .... this log stops before the alert box skipped line (in the successful log). Do not know if this alert message which is the first task in the workflow and is skipped after 3 sec is causing this issue. The next batch of machines will not use this alert task at all.

Last edited by Vij Na (2016-12-08 21:06:16)

Offline

Board footer

Powered by FluxBB