You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2016-06-15 21:58:29

cemyers
Member
Registered: 2016-06-02

cannot login, authentication failed

Hi,

I have set up a new DS server and it won't let me login. This problem has occurred during multiple attempts to set up DS. I have uninstalled DS, re-installed, and
cannot login. Some times I can login but now it keeps giving an error. I'm out of ideas as to why this is happening.

I used DS Assistant, with https and the name of the server/repository folder
The repository folder is set up to allow file sharing over both SMB and AFP in the File Sharing settings of Xserve
I used the name of an admin account during DS Assistant setup, so the account is valid
DS Admin app gives the error: Authentication Failed

Imac 21.5 inch Mid 2011
2.5GHz Intel Core i5 with 8 GB RAM

OS X El Capitan 10.11.5

Apple Server Version 5.1.5

We tried setting up the repository as a local folder in the Documents folder of one of the admin user called it 'DSMasters'

Charles Myers
Computer Specialist
UMBC, University of Maryland Baltimore County

Offline

#2 2016-06-16 17:54:08

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: cannot login, authentication failed

Can you access the repository from a different machine, over AFP or SMB, using the admin account credentials?

Offline

#3 2016-06-16 21:18:27

cemyers
Member
Registered: 2016-06-02

Re: cannot login, authentication failed

Yes. I can login with the user, the user is a local network account, and I can get to it from another iMac
on the network, using either AFP or SMB.

Offline

#4 2016-06-17 15:01:44

cemyers
Member
Registered: 2016-06-02

Re: cannot login, authentication failed

The Server local network users can connect to the server from another iMac via SMB and AFP, and can login to the file shares.
So users can login to the server, but DeployStudio rejects the login when I run DS Admin...

I tried a few things…

Repaired permissions on the system
I created a new Local Network user in Server
I created a new File Share in Server for the repository
I uninstalled DeployStudio and re-installed it

I ran the DS Assistant and it worked
Then I ran the DS Admin, and the Authentication Failed, it rejected the login, even though the login works for the server
I uninstalled DS again, and ran DS Assistant again. Same result, DS Admin rejects the login.

Offline

#5 2016-06-20 18:29:19

kdpslider
Member
Registered: 2015-12-11

Re: cannot login, authentication failed

> cemyers wrote:


I ran the DS Assistant and it worked
Then I ran the DS Admin, and the Authentication Failed, it rejected the login, even though the login works for the server
I uninstalled DS again, and ran DS Assistant again. Same result, DS Admin rejects the login.


>>
When you get through the assistant, near the end, it will prompt for access privileges so groups can access parts of the apps.  These are DS Admin, DS Assistant, and then DS Runtime.  The first two only allow for one group, while the final box allows for multiple groups.  Put in the 'admin' group for the first two, (or a group that your user is in).  The last box, put any number of groups in your network domain into this box that you want to be able to log into the runtime.

Offline

#6 2016-09-13 16:45:32

DCKincaid
Member
Registered: 2014-07-24

Re: cannot login, authentication failed

I am having this same problem as of today. I cannot get logged back into the DeployStudio Admin console. It was working this morning and I logged out of it like I usually do, but when I went to log back in it told me the password was wrong. Nothing has changed on my end as far as I can tell. DS Assistant will not accept the password either. Any suggestions? I have tried everything that cemyers has.

I am on DeployStudio version 1.7.4.4
Mac Server version 5.1.7

Mac Mini Server (Mid 2010)
El Capitan 10.11.6
2.66 GHZ Intel Core 2 Duo
1TB SSD
8GB 1333 MHz DDr3

Offline

#7 2016-09-13 17:39:29

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: cannot login, authentication failed

> cemyers wrote:

> I created a new Local Network user in Server

Does it work with just a plain old local user (admin account) to connect to the server?

Offline

#8 2017-04-06 02:26:28

MinimalMac
Member
Registered: 2017-04-05

Re: cannot login, authentication failed

Delete the DeloyStudio Plist file  in /Library/Preferences.  Rerun the DeployStudio Server setup.  Then after that works to get into the admin console, rerun the assistant to create new netboot image.

Offline

Board footer

Powered by FluxBB