You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2015-11-24 22:22:01

another_deploystudio_user
Member
Registered: 2015-11-24

Authentication failed when connecting immediately after set up

I have a machine running a fresh install of 10.11.1 and I have installed DeployStudio 1.6.18 on it.  There is a single local administrator account.  I can run the DeployStudio Assistant and set up the server with a SMB repository successfully.  However, once I've finished the set up process, I try to log in with the credentials I used during set up but DeployStudio Admin simply reports:

"Authentication failed

The server 'https://127.0.0.1:60443' has rejected your login and/or password."

It does the same thing if I use the fully-qualified domain name for the host.  I have uninstalled and reinstalled DeployStudio, making sure that I have not made any typos during the set up process.  In the Console logs, every failed authentication creates the following log entries.  I've tired repairing my keychain to no effect.  Does anyone have an idea what's going on here?

------------------------------

11/24/15 1:18:52.503 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: raw entitlement values: <CFBasicHash 0x7faf80e10750 [0x7fff7873c390]>{type = mutable dict, count = 0,
entries =>
}
11/24/15 1:18:52.504 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: original ag: (null)
11/24/15 1:18:52.504 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: newly parsed ag: (null)
11/24/15 1:18:52.504 PM secd[301]:  __security_simulatecrash Simulating crash, reason: keychain entitlement(s) missing, code=53c00007
11/24/15 1:18:52.504 PM secd[301]:  __security_simulatecrash_link SimulateCrash not available
11/24/15 1:18:52.504 PM secd[301]:  securityd_xpc_dictionary_handler DeployStudio Adm[1211] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.504 PM DeployStudio Admin[1211]:  SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.512 PM DeployStudio Admin[1211]: ============================ connectToServer: [networkBrowser stop] ============================
11/24/15 1:18:52.581 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: raw entitlement values: <CFBasicHash 0x7faf80d094a0 [0x7fff7873c390]>{type = mutable dict, count = 0,
entries =>
}
11/24/15 1:18:52.581 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: original ag: (null)
11/24/15 1:18:52.581 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: newly parsed ag: (null)
11/24/15 1:18:52.581 PM secd[301]:  __security_simulatecrash Simulating crash, reason: keychain entitlement(s) missing, code=53c00007
11/24/15 1:18:52.581 PM secd[301]:  __security_simulatecrash_link SimulateCrash not available
11/24/15 1:18:52.582 PM secd[301]:  securityd_xpc_dictionary_handler DeployStudio Adm[1211] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.582 PM DeployStudio Admin[1211]:  SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.754 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: raw entitlement values: <CFBasicHash 0x7faf80d006c0 [0x7fff7873c390]>{type = mutable dict, count = 0,
entries =>
}
11/24/15 1:18:52.754 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: original ag: (null)
11/24/15 1:18:52.754 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: newly parsed ag: (null)
11/24/15 1:18:52.754 PM secd[301]:  __security_simulatecrash Simulating crash, reason: keychain entitlement(s) missing, code=53c00007
11/24/15 1:18:52.754 PM secd[301]:  __security_simulatecrash_link SimulateCrash not available
11/24/15 1:18:52.754 PM secd[301]:  securityd_xpc_dictionary_handler DeployStudio Adm[1211] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.754 PM DeployStudio Admin[1211]:  SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.766 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: raw entitlement values: <CFBasicHash 0x7faf80d01340 [0x7fff7873c390]>{type = mutable dict, count = 0,
entries =>
}
11/24/15 1:18:52.766 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: original ag: (null)
11/24/15 1:18:52.766 PM secd[301]:  secTaskDiagnoseEntitlements MISSING keychain entitlements: newly parsed ag: (null)
11/24/15 1:18:52.766 PM secd[301]:  __security_simulatecrash Simulating crash, reason: keychain entitlement(s) missing, code=53c00007
11/24/15 1:18:52.766 PM secd[301]:  __security_simulatecrash_link SimulateCrash not available
11/24/15 1:18:52.766 PM secd[301]:  securityd_xpc_dictionary_handler DeployStudio Adm[1211] copy_matching Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.766 PM DeployStudio Admin[1211]:  SecOSStatusWith error:[-34018] Error Domain=NSOSStatusErrorDomain Code=-34018 "client has neither application-identifier nor keychain-access-groups entitlements" UserInfo={NSDescription=client has neither application-identifier nor keychain-access-groups entitlements}
11/24/15 1:18:52.807 PM DeployStudio Admin[1211]: [DSServerClientController valueForURI:error:] error: The operation couldn’t be completed. (NSURLErrorDomain error -1012.) (-1012)

Offline

#2 2015-12-01 22:02:20

another_deploystudio_user
Member
Registered: 2015-11-24

Re: Authentication failed when connecting immediately after set up

I'm replying to my own topic since I have been able to proceed.  The issue appears to be that I cannot select a local user account when setting up the 3 different permissions in DeployStudio Assistant.  Instead of using my local administrator account I populated all three fields with the local user group "admin" and the problem has gone away entirely.  I had a working configuration in the past and I think that I had specified an individual user account, not the "admin" group, but as I don't know with any certainty, I can't say whether this is a bug of some kind or if it's just something I am misremembering.

Hopefully this will help someone else!

Offline

#3 2015-12-08 19:00:03

jagreen97
Member
Registered: 2015-09-28

Re: Authentication failed when connecting immediately after set up

I have the same problem with 1.6.12 and 1.6.18. Same solution is to have just local groups installed and not pulling from OD or AD.

Offline

Board footer

Powered by FluxBB