You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2015-11-25 20:03:30

samlap
Member
From: Van, CA
Registered: 2015-11-25

netinstall sees the deploystudio image but can't boot from there

Hi everyone,

I have OS X 10.10.5 with server admin 5.0.15 installed with NetInstall services running. I then installed DS and configured everything. I created a workflow to image my captured image. When I boot my Mac, I can see the netInstall image but wen I try to boot it,  it keeps running for a while and goes to my regular boot.

Is there anything I am missing?

Thanks in advance.

Offline

#2 2015-11-25 20:30:44

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: netinstall sees the deploystudio image but can't boot from there

What specific model Mac?
What OS version is the netinstall image?
Which version of DeployStudio?
Can you see any errors if you netboot in verbose mode?

Offline

#3 2015-11-25 20:59:31

samlap
Member
From: Van, CA
Registered: 2015-11-25

Re: netinstall sees the deploystudio image but can't boot from there

I created netBoot image from Mac Pro (Mid 2010)
OS version:  10.10.5
But I am trying to image it to iMac. Quick question, do I need to create netBootImage from the same iMac that I trying to reimage?

Offline

#4 2015-11-25 21:11:58

samlap
Member
From: Van, CA
Registered: 2015-11-25

Re: netinstall sees the deploystudio image but can't boot from there

I mean my iMac are late 2013.

Offline

#5 2015-11-25 21:50:19

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: netinstall sees the deploystudio image but can't boot from there

Always create your netboot image from your newest hardware. It will be backward compatible as a rule*.

* Caveat - Brand new hardware that ships with a custom build of the currently available OS X version may be an issue until the next "Unified" OS X version is released, which would support that new hardware and older hardware as well.
In the case of new hardware with a custom build of the currently available OS X version, you may need to create another netboot set just for those units.
When the next "unified" version of the OS is released, you can create a new netboot image that will boot all your hardware, and retire the older netboot images (after fully testing the new one of course).

Offline

#6 2015-11-25 21:59:18

samlap
Member
From: Van, CA
Registered: 2015-11-25

Re: netinstall sees the deploystudio image but can't boot from there

Great. Thank you so much for your help.

Offline

#7 2015-11-25 22:04:44

samlap
Member
From: Van, CA
Registered: 2015-11-25

Re: netinstall sees the deploystudio image but can't boot from there

sorry one more thing, do we need to have the same OS which we are trying to image or we can use any OS to create NBI and after that we can use image file to restore the HD?  Because I think the purpose of NBI is to boot.

Offline

#8 2015-11-25 22:17:31

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: netinstall sees the deploystudio image but can't boot from there

If you don't anticipate rolling out 10.11.x anytime soon (or you don't expect any late 2015 iMacs), then a 10.10.5 netboot image should work fine.

If you decide to test/deploy 10.11.x you'll need a 10.11.x netboot image (10.11.1, would be preferable at this time, I believe).


So, If you build the netboot on the 2013 iMac, you should be able to netboot those and earlier models. If you receive a 2014 or 2015 model, be aware that you "might" need to create a new netboot set from those (most certainly for late 2015 as they were born with 10.11.x on them, and cannot boot an earlier version).

Last edited by Meat (2015-11-25 22:26:19)

Offline

Board footer

Powered by FluxBB