You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2015-01-21 19:54:44

ComputerConnection
Member
Registered: 2015-01-20

NetBoot Sets For Older OSes

We would like the ability to make NetBoot sets for older OSes. We don't need the ability to run Deploy Studio Server on older OSes. Running DS Admin, DS Assistant and DS Runtime on Snow Leopard or Mavericks is fine. But we would like to be able to create NetBoot sets that work with Deploy Studio Server and which can be run on older machines.

Our organization refurbishes donated computers. We agree to wipe the hard drives of donated computers and the easiest way for our volunteers to do that is as part of a Deploy Studio workflow.

Most of the older machines end up going to a recycler. But we still have to securely erase the drives. So, if we could make NetBoot Sets for some of the older OSes, that would be great.

Offline

#2 2015-01-23 16:01:50

PaintedTurtle
Member
Registered: 2010-06-27

Re: NetBoot Sets For Older OSes

+1
That would be great.

FYI, we have had some success in getting older older Leopard 10.5 NetBoot sets to work with version 1.6.12. But none with Tiger 10.4 NBSs.

Offline

#3 2015-01-23 19:33:37

ComputerConnection
Member
Registered: 2015-01-20

Re: NetBoot Sets For Older OSes

For us, getting a Leopard netboot set to work, wasn't all that reliable. We are thinking of taking an old G5 and putting 10.5 or 10.4 server on it, and running the older DS rc20, which we understand was supposed to support some of the older OSes. However, we could not find anyone at Apple who would sell us a copy of 10.4 or 10.5 server. We now think that we may have a copy, but we don't have everything working yet.

But that is now another machine that we have to support, backup, etc. And we fear that when Apple brings out 10.11, that support for 10.6 and possibly 10.7 may fall off the cliff and we may need a third machine to do 10.6.  So, the ability to run Netboot sets based on older OSes, would be a really nice solution.

Offline

#4 2015-02-02 21:12:15

ComputerConnection
Member
Registered: 2015-01-20

Re: NetBoot Sets For Older OSes

What if we turned off the checks on the "sys_builder.sh" script at /Applications/Utilities/DeployStudio\ Admin.app/Contents/Applications/DeployStudio\ Assistant.app/Contents/Resources/sysBuilder/ ??

Offline

#5 2015-02-02 22:24:37

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: NetBoot Sets For Older OSes

I guess (not tested recently) that you can use an older netbook set (say 10.5.8 with DSS DS1.5.17) and share  a Repository from the latest server (say 10.9.5 DSS 1.6.12)
AS LONG AS your workflows are 'simple'.
The scripts behind the workflows are (most) not version specific.
Specifically the workflows that generate users, bind to AD etc ARE version specific, and will probably fail.
But if you just deploy an image with basic software (10.4-10.6), and no users installed (so startup with setup assistant) I give you 90% chance it will just work. (after you disabled the version mismatch warning!)

Just try it out! (and let us know)
You do know that creating the 10.5.8 netboot set must be done on a 10.5.8 mac,
10.5.8 will boot almost any Mac that is worth working on these days (like G4 eMac's starting from 2nd generation)

Offline

#6 2015-02-09 21:20:18

ComputerConnection
Member
Registered: 2015-01-20

Re: NetBoot Sets For Older OSes

Thanks for the hint. That helps.

If anyone figures out how to get the older OSes better supported, please let us know.

Offline

#7 2015-02-16 01:47:26

hunty1
Member
Registered: 2014-11-11

Re: NetBoot Sets For Older OSes

You might be better off just building your own netboot images, and having a automator action or apple script run that will wipe the drives, you don't really need deploy studio

Offline

#8 2015-04-13 19:35:02

ComputerConnection
Member
Registered: 2015-01-20

Re: NetBoot Sets For Older OSes

That would be better if we were a full-time, paid, organization. However, we are a not-for-profit, volunteer organization. And that means that we have to train our volunteers. And it would be nice to not have to train them on something else. (Some of them are hard to train Windoze users who get confused when they go to select a startup disk and see the install server comment next to the DS NetBoot Set. ;-)
And it is extra work for us.

But, it may well be that this is the best choice.

Offline

#9 2015-04-13 22:46:58

PaintedTurtle
Member
Registered: 2010-06-27

Re: NetBoot Sets For Older OSes

Wow!! Training Widows users. That must be a real challenge.  ;-)  ;-)

Offline

Board footer

Powered by FluxBB