You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2014-01-02 20:58:18

jimkirk
Member
Registered: 2010-02-04

Nightly in Production

Is anyone using the latest nightly build in production?  We have received around 50 of the latest models of laptops and iMacs and will soon be receiving around 20 Mac Pros.  These will all be needing Mavericks v10.9.1.  I am currently debating between using 1.6.3 and the nightly build to upgrade my production server which is currently at 1.6.0.  Unfortunately, I have to have this working by end of next week.

Any suggestions?

Offline

#2 2014-01-02 23:22:04

Strawgate
Member
Registered: 2013-07-15

Re: Nightly in Production

We have been having stability issues with our nightly instance.

In production we still use 1.5.17 and deploy Mavericks without issue.

Offline

#3 2014-01-03 09:14:22

Joon
Member
Registered: 2012-02-15

Re: Nightly in Production

Currently the Latest Macbook Pro's still have a forked build of OSX Mavericks(10.9.1), the retail installation does -NOT- work on them, be sure to keep this in mind.
I can only speculate but i'm quite sure the Mac Pro's are the same, meaning you would have to build images based on their forked build as well(Netboot set and deployment image)

Deploying on such a large scale i wouldn't recommend using the nightly.
Though the only issue i've had with it that it would randomly unmount the repository, this may not happen often but it would make you have to re-do the workflow.
( see: http://deploystudio.com/Forums/viewtopic.php?id=5396 )

I would assume any -recent- DS version would work fine as long as you pay attention to the OSX builds your using for which computer.
Im hoping this will be solved with 10.9.2 ... this is causing me some pain too :c

Last edited by Joon (2014-01-03 09:20:02)

Offline

#4 2014-01-03 16:18:26

jimkirk
Member
Registered: 2010-02-04

Re: Nightly in Production

Thanks for the replies!

Strawgate, when you are building your Netboot set, are you using the 1.6.3 DeployStudio Assistant and just checking ignore version mismatch before uploading to the server?  The 1.6.0 Assistant doesn't work with Mavericks.

Offline

#5 2014-01-03 17:40:08

Strawgate
Member
Registered: 2013-07-15

Re: Nightly in Production

Our DeployStudio server runs 10.7.5
We built our netboot set on the server so it is running 10.7.5. We use it to image mid 2013 iMacs and MacBook Pros without issue.

Offline

#6 2014-01-03 19:29:30

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: Nightly in Production

Having problems here. 10.6.8 server with nightly "DeployStudioServer_v1.6.4-NB131113".
Test build and deploy machines are late 2013 iMacs and MacBook Pros.

Very slow to capture, and very slow to deploy. Using unicast in my testing so far. :P

Also, it doesn't appear to capture the recovery partition...

Offline

#7 2014-01-07 00:58:06

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: Nightly in Production

Image captures aren't the problem. It's the network transfer that is running slow. It took 600+ minutes. It did create the recovery partition (yay!)

Upon deploying, the image succeeds (imaging time was not nearly as slow), but the transfer of the post-install packages fails.

I have done some ground work to assure the Server's drives are healthy (yes) and am going a full backup before installing the server combo updater.
I'm suspecting the netboot image (10.9) at this point, but...

Last edited by Meat (2014-01-07 00:59:05)

Offline

Board footer

Powered by FluxBB