You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-10-26 16:13:34

ultramizer
Member
Registered: 2016-01-11

Creating a new APFS Clone

Hi

We are on Deploy Studio 1.7.8

So i have checked the forums, and most posts regarding APFS i have found, are related to deploying images onto APFS Volumes or Netbooting APFS Macs etcetera. Now we have some of the newest MacBook Pro's laying around, that we need to put a thick image onto. We are still working with Thick images, since those are the easiest for us to work with, since we are a desktop publishing company and we have millions of settings we need, so it's just been really easy using thick images. Here's our setup:
We have a MacPro, an old silver tower one, i think the latest before the black can came out. In there is an SSD containing 5 Partitions, each partition has a complete Mac OS installed for a different department of our company. There is one for administration, production, photography and so on. Until now, these have all been 10.12 clones with the latest updates and on HFS+ volumes.
When there were any updates, i would simply boot into the partition of the departement clone i would like to do the updates and then boot into our DeployStudio NetBoot Set and make a new Master, which we would then use in workflows to image new macs. This has worked like a charm.

Now i updated the first of 5 clones with High Sierra. And here's where the issue starts. Since the underlaying disk of that clone is an SSD, it has converted that particular partition to APFS, the other clones on the same disk are still on HFS+. Now when i try to make a new Master using the "Disk Image" Workflow inside Deploy Studio, it stops immediately with the following error (Screenshot attached and Logfile attached)

https://i.imgur.com/nH8cWvX.png

–––––––––––––––––––––––––––––––––––––––––––––––
2017-10-26 16:57:40.489 DeployStudio Runtime.bin[387:19469] Running workflow: 'Create New Master' (04062220-1111-BBBB-2222-000000000000)
2017-10-26 16:58:34.225 DeployStudio Runtime.bin[387:20073] Image action:
2017-10-26 16:58:35.756 DeployStudio Runtime.bin[387:20073] '/Volumes/Clone Projektleitung 10.12' used: 29233.6 MB
2017-10-26 16:58:35.756 DeployStudio Runtime.bin[387:20073] '/Volumes/Clone Projektleitung 10.12' free: 35262.3 MB
2017-10-26 16:58:35.756 DeployStudio Runtime.bin[387:20073] '/tmp/DSNetworkRepository/Masters/tmp' free: 1622268.1 MB
2017-10-26 16:58:35.990 DeployStudio Runtime.bin[387:20073] /usr/sbin/diskutil enableOwnership /dev/disk2s1 2>&1
2017-10-26 16:58:36.095 DeployStudio Runtime.bin[387:20073] File system user/group ownership enabled
2017-10-26 16:58:36.098 DeployStudio Runtime.bin[387:20073] Setting boot device to '/dev/disk2s1'.
2017-10-26 16:58:36.098 DeployStudio Runtime.bin[387:20073] "/Applications/Utilities/DeployStudio Admin.app/Contents/Frameworks/DSCore.framework/Resources/Tools/physicaldiskid.sh" /dev/disk2s1 2>&1
2017-10-26 16:58:36.324 DeployStudio Runtime.bin[387:20073] /bin/rm -f /tmp/DSNetworkRepository/Masters/tmp/master_CloneProjektleitung10.12_17.10.26_16.58.i386.apfs.dmg 2>&1
2017-10-26 16:58:36.338 DeployStudio Runtime.bin[387:20073] /usr/bin/hdiutil create -uid 0 -gid 0 -mode 755 -format UDZO -fs APFS -puppetstrings -srcfolder "/Volumes/Clone Projektleitung 10.12" /tmp/DSNetworkRepository/Masters/tmp/master_CloneProjektleitung10.12_17.10.26_16.58.i386.apfs.dmg 2>&1
2017-10-26 16:58:40.054 DeployStudio Runtime.bin[387:20073] could not access /Volumes/Clone Projektleitung 10.12/./usr/bin/pstruct5.18 - No such file or directory
2017-10-26 16:58:41.429 DeployStudio Runtime.bin[387:20073] hdiutil: create failed - No such file or directory
2017-10-26 16:58:41.432 DeployStudio Runtime.bin[387:20073] -> Image action completed.
2017-10-26 16:58:41.432 DeployStudio Runtime.bin[387:20073] Imaging failure (elapsed time: 0.09 minutes)
2017-10-26 16:59:03.800 DeployStudio Runtime.bin[387:13916] Umounting repository share point...
2017-10-26 16:59:03.801 DeployStudio Runtime.bin[387:13916] /sbin/umount -f /tmp/DSNetworkRepository 2>&1
2017-10-26 16:59:04.190 DeployStudio Runtime.bin[387:13916] /bin/rmdir /tmp/DSNetworkRepository 2>&1
–––––––––––––––––––––––––––––––––––––––––––––––

Now i have no clue why it doesn't work. Is this officially not supported? I have read that some support for APFS is included since DeployStudio 1.7.7, and that imaging should technically work.

Can someone help me out on this?

Thank you!

Offline

#2 2017-11-01 22:16:01

Phych
Member
Registered: 2012-04-05

Re: Creating a new APFS Clone

1.7.8 has "official" support for APFS.

Offline

#3 2017-11-01 23:29:36

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: Creating a new APFS Clone

Is your netboot OS 10.13? That is required for APFS support (both imaging as restoring)

I did see errors like this:

2017-10-26 16:58:40.054 DeployStudio Runtime.bin[387:20073] could not access /Volumes/Clone Projektleitung 10.12/./usr/bin/pstruct5.18 - No such file or directory

when I mounted an APFS volume from 10.12.6.

Offline

Board footer

Powered by FluxBB