You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-09-12 15:12:28

terryj
Member
Registered: 2009-05-08

DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

DSS 1.7.8 and 2017 5k iMacs (3.4ghz/512GB SSD) running 10.12.6....Created USB Bootable key, said it was successful, but when I option reboot to it, it boots into an OSX Installer? not the DSS Runtime? But good news, creating the .nbi on the same machine using DSS 1.7.8, creates an .nbi that I can netboot from...so glass half full maybe?


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#2 2017-09-12 16:51:19

mediocer
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

USB boot works for me on 176, 177 and 178.  But Netbooting across subnets is not working with the new Apple Hardware.

Offline

#3 2017-09-12 18:15:46

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

mediocer: Did you whitelist your netboot server with SIP on the target machines?

Last edited by Meat (2017-09-12 18:16:03)

Offline

#4 2017-09-12 20:52:51

terryj
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

@mediocer: I'm running an octopus setup ( mac mini OSX/ DSServer handles dhcp/dns, connected to two daisychained 24port GB Cisco 2960's on a wheeled cart) so I don't do it across subnets ( always been a pain when tried before)

Attempting to re-create the USB booter now with a different USB stick. The one I used has been re-used since version 1.6.6, so it may be getting on its last legs...


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#5 2017-09-13 17:35:43

terryj
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

Tried with a brand new USB drive purchased, and the system is unable to make a USB booter now, just keeps coming up with "Creation Failed". Restarted the 2017 iMac also, still no go.

Here are the logs:

default    16:37:37.758056 -0500    DeployStudio Assistant    User:501
default    16:37:37.758107 -0500    DeployStudio Assistant    System version:10.12
default    16:37:37.758147 -0500    DeployStudio Assistant    Architecture:i386
default    16:37:38.300182 -0500    DeployStudio Assistant    Volume Recovery HD on /dev/disk0s3 mounted
default    16:37:38.901386 -0500    DeployStudio Assistant    Volume Recovery HD on disk0s3 unmounted
default    16:37:38.937326 -0500    DeployStudio Assistant    Started erase on disk2s1 NO NAME
default    16:37:38.938348 -0500    DeployStudio Assistant    Unmounting disk
default    16:37:39.354078 -0500    DeployStudio Assistant    Erasing
default    16:37:48.991171 -0500    DeployStudio Assistant    Initialized /dev/rdisk2s1 as a 29 GB case-insensitive HFS Plus volume with a 8192k journal
default    16:37:48.992005 -0500    DeployStudio Assistant    Mounting disk
default    16:37:49.078688 -0500    kernel    hfs: mounted DeployStudioRuntimeHD on device disk2s1
default    16:37:49.094555 -0500    DeployStudio Assistant    Finished erase on disk2s1 DeployStudioRuntimeHD
default    16:37:49.130415 -0500    fseventsd    could not open <</Volumes/DeployStudioRuntimeHD 1/.fseventsd/fseventsd-uuid>> (No such file or directory)
default    16:37:49.130470 -0500    fseventsd    Failed to load UUID.  Removing all old log files in /Volumes/DeployStudioRuntimeHD 1/.fseventsd
default    16:37:49.130556 -0500    fseventsd    log dir: /Volumes/DeployStudioRuntimeHD 1/.fseventsd getting new uuid: 0464C7AD-73F8-4874-9DE1-4CEF68FCF1BF
default    16:37:49.136048 -0500    DeployStudio Assistant    vsdbutil: failed to getattrlist finderinfo for /Volumes/DeployStudioRuntimeHD: Invalid argument
default    16:37:49.136136 -0500    DeployStudio Assistant    vsdbutil: no valid volume UUID found on '/Volumes/DeployStudioRuntimeHD': Invalid argument
default    16:37:49.136292 -0500    DeployStudio Assistant    An error occured while modifying the "/dev/disk2s1" device.
default    16:37:49.138479 -0500    DeployStudio Assistant    Aborting sys_builder_rp.sh v2.3 (Tue Sep 12 16:37:49 CDT 2017)
default    16:37:49.138539 -0500    DeployStudio Assistant    RuntimeAbortScript


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#6 2017-09-13 21:51:36

mjsanders
Member
From: Schiedam, Netherlands
Registered: 2008-09-02
Website

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

I see both
/Volumes/DeployStudioRuntimeHD 1/
as
/Volumes/DeployStudioRuntimeHD/

Maybe a leftover from previous attempts confuses the assistant?
reboot your Mac to clear the /Volumes/ directory from leftovers.

Offline

#7 2017-09-14 15:22:21

terryj
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

HD was the first USB drive that failed, HD 1 was the second USB drive that failed.
HD 1 was originally named Untitled, and was selected as such when making the USB drive, so that shouldn't had caused an issue.....?


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#8 2017-09-14 15:31:01

terryj
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

reboot, new USB Drive, same thing.
Ironically, it still showed after the reboot that besides the "Untitled" USB drive, that if "found" a drive called "DeployStudio1".
(which of course doesn't exist)


Apple Certified Technical Coordinator 10.x
Apple Certified Support Professional 10.x
Apple Certified Macintosh Technician 10.x

Offline

#9 2017-09-21 14:45:18

mediocer
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

> Meat wrote:

> mediocer: Did you whitelist your netboot server with SIP on the target machines?

Yes, as far as I can tell... It is open.  Older netboot sets work on older machines.  Just not via nbi netboot on newer USB-C Apple computers.

Offline

#10 2017-09-21 14:48:40

mediocer
Member
Registered: 2009-05-08

Re: DSS 1.7.8 & 2017 5k iMacs (10.12.6) issues w bootable USB, nbi works

> Meat wrote:

> mediocer: Did you whitelist your netboot server with SIP on the target machines?

I did some research on this and no, I am not, not on the newer machines.
What is the process?
run this command on the computers I am trying to netboot: csrutil netboot add "address"

Offline

Board footer

Powered by FluxBB