You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-07-27 00:33:09

pknz
Member
Registered: 2015-07-08

Testing 10.13 High Sierra

I've just begun to test 10.13 (public beta 3) with 1.7.5

I've tried running a workflow with no base image, just packages and scripts but the ds_finalize script doesn't appear to execute.

Mac just reboots after the workflow finishes and goes to the login screen.

All scripts and files are intact in /etc/deploystudio no ds_finalize log is created.

Is this the current expected behaviour with APFS and High Sierra (haven't yet tested 1.7.6, but release notes didn't indicate any thing that would help this).

Thanks!

Offline

#2 2017-07-28 10:40:52

chrisb42
Member
Registered: 2014-03-14

Re: Testing 10.13 High Sierra

In my limited testing with High Sierra, if your machine was converted to using APFS, then DeployStudio will not work, as it doesn't know anything about the new filesystem and - probably more important - the new disk layout. On a High Sierra machine with APFS, Disk Utility reports that there are 4 volumes on the disk, and again, DS does not know anything about the changes introduced with APFS.

I had an old iMac that didn't get converted to APFS with an early seed build of High Sierra, so on that DS worked perfectly fine, minus some (apparently inconsequential) error messages with the finalize script IIRC.

So we'll have to wait for a DS update that is capable of dealing with APFS volumes before we can deploy High Sierra builds.

Cheers,

-Christian

Offline

Board footer

Powered by FluxBB