You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-07-25 18:41:29

bhusvar
Member
Registered: 2017-07-25

Firmware Security workflow removes startup disk

Hi there,

I'm attempting to use a DeployStudio workflow to set a firmware password on my Macs after they've been re-imaged. What I want to do is have a Firmware Security task inside my re-image workflow, and then a separate workflow that only contains the Firmware Security task to use on machines that don't require a re-image. I set up a workflow where the only task is the Firmware Security. The settings are as follows:

Firmware Security: At Startup Manager Only
Passcode: (10 character passcode with number and capital letter in it)
Old Passcode: *blank*
Automate: Enabled

When I use this workflow, the workflow completes successfully, however when the computer reboots, I get the blinking question mark folder as if the startup disk was changed. The firmware password seems to have worked since if I reboot and hold down option, it asks for the firmware passcode that applied in the workflow. I also tried the same workflow, but put the same passcode in the "Old Passcode" field as well, but get the same result.

If I boot into the recovery partition and remove the firmware passcode with the Firmware Utility, the computer will reboot as normal into the correct disk.

I am running this workflow on a macOS 10.12.5 installation and the DeployStudio version is 1.7.6.

Any help that can be provided is greatly appreciated.

Thanks!
-Brandon

Offline

#2 2017-08-10 22:01:33

fiav
Member
Registered: 2015-03-12

Re: Firmware Security workflow removes startup disk

I found that in that situation, I need to boot into MacOS and set the startup disk manually. We have experienced it quite a bit at work as we set a number of machines to have firmware passwords on.

Offline

Board footer

Powered by FluxBB