You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-06-13 18:14:03

DsUser2017
Member
Registered: 2017-06-13

10.12.5 with DS 1.7.6

Hi.

I'm trying to get Deploy Studio to work with my Sierra images, but I keep getting the infamous black screen with the cursor when I boot clients through netboot. When I first installed the OS, it was version 10.12. However, Apple's Server app won't download if I don't update it to 10.12.5, which I think is creating the problem.

Now, when I go through the Netboot image creation process on my server, I keep getting the error "System Version Mismatch".

"The recovery partition system doesn't match your boot system version (10.12 vs 10.12.5). The resulting NetBoot set may not work properly."

Based on some of the posts, this may happen because my Recovery partition stayed at 10.12, while my OS is 10.12.5 and that may be causing the black screen on the machine that's trying to boot to the server.

Did anyone run into this problem? I would appreciate if you could let me know.

Thanks.

Offline

#2 2017-06-13 20:03:43

DsUser2017
Member
Registered: 2017-06-13

Re: 10.12.5 with DS 1.7.6

I actually managed to fix it using this:

https://forums.macrumors.com/threads/how-to-update-the-recovery-partition-to-a-10-12-4-version.2039184/

The Terminal window ended with an error about not being able to update .plist, but after I restarted, holding down ALT, I was able to see that the Recovery Partition was updated to 10.12.5 also. This is on the Server by the way. Once I booted up into OsX, I recreated the netboot image, this time didn't get any version mismatch errors.

From that point on, I was able to boot the other client machine into DS. I noticed it takes considerably longer to boot. Initially you DO see a black screen, but after about another minute the whole interface loads up. I was able to pull and restore an image successfully.

Hope this helps someone avoid days of frustration.

Offline

#3 2017-06-13 22:16:34

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: 10.12.5 with DS 1.7.6

Thanks! :)

Offline

Board footer

Powered by FluxBB