You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-05-24 20:53:46

FrozenApple
Member
Registered: 2017-05-24

dseditgroup command not working as a script

Good day all,

Just trying to run this script in a workflow which would add members of an Open Directory group called 'macbookadmins' to the local admin group on the client Mac.

It works if I run it manually on the client, but not via DS. The error log states "group not found".

I've tried it with and without the local administrator user credentials in the script.

Thanks everyone!


#!/bin/sh

#Add MacBook Admins OD group to local admins
dseditgroup -o edit -n /LDAPv3/<our Mac server> -u <username> -P <password> -a macbookadmins -t group admin

exit 0

Offline

#2 2017-05-25 15:11:09

FrozenApple
Member
Registered: 2017-05-24

Re: dseditgroup command not working as a script

Resolved after simplifying the command and adding sudo:

sudo dseditgroup -o edit -a macbookadmins -t group admin

Also checked Postponed execution with Last Restored Volume.

Last edited by FrozenApple (2017-05-25 15:20:17)

Offline

Board footer

Powered by FluxBB