You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-02-22 08:40:40

PaintedTurtle
Member
Registered: 2010-06-27

NetBoot Set Utility Issues DS 1.7.6 with 10.10.5 Yosemite

There seems to be some problem with 10.10.5 Yosemite Netboot Sets with Deploy Studio 1.7.6. The utilities will not work. You cannot open disk utility, you cannot open startup disk utility, you cannot open terminal, etc.

The problem seems to be unique to 10.10.5 Yosemite. We have created Netboot sets for 10.7, 10.8, 10.9, 10.11 and 10.12. All the other Netboot Sets seem to work as expected. But not 10.10.5.

We tried multiple times. We erased drives, downloaded fresh Yosemite installers from the Apple App Store, etc. But the utilities on the resulting Netboot set do not work.

Our understanding is that the Netboot Sets get created from the recovery partition, so we tried booting from the recovery partition, to see if the utilities work there. They do. So there seems to be nothing wrong with the recovery partition.

My personal guess is that there is some needed system resource, that is not getting copied to the NetBoot Set for this OS version.

Would like to provide a copy of the error log that we see on the screen, when we try to open a utility. But am not sure how to get that.

Offline

#2 2017-02-22 20:27:14

PaintedTurtle
Member
Registered: 2010-06-27

Re: NetBoot Set Utility Issues DS 1.7.6 with 10.10.5 Yosemite

Thought that we should note the workaround, in case others might be concerned about this problem.

As far as we can tell, a Netboot Set created with either 10.9 or 10.11 will push a 10.10 image onto a supported Mac with no problems. The OS version of the NetBoot Set and the OS version of the image to be installed, do NOT have to match.

Assuming that Mactracker is correct, and that we're using it properly, there are no Mac models for which Mac OS-X v 10.10 Yosemite is the last supported version. Assuming adequate RAM, any Mac which will run Yosemite, should also run El Capitan. So, while this DOES appear to be a bug, it also isn't one that would be expected to cause a lot of problems.

The one minor problem for us, is that we do have a group of volunteers who help with the imaging. And they seem to want to boot from an NetBoot Set of the same OS as the image they wish to install. So, it is a training issue. (We also have to keep telling them, to ignore the fact that the DS NBS says, "Install mac OS Server" in the Startup Disk Preference Pane, to the right of the image name.

Offline

Board footer

Powered by FluxBB