You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2017-02-15 20:09:19

s10010001
Member
Registered: 2017-02-15

Question about base images, problems with 10.12

Hello,

First time poster here. We have been using DS at our company for a little more than a year now. I am the primary manager of the system. We have about 700 Macs and 5k PCs. We recently standardized on 10.12 and are starting to see some issues. Were seeing some odd things happening with the network adapters after restoring there is a lot of extra adapters, or mis-named adapters. Sorta random but were were talking with Apple about some other things and mentioned how we used DS and he strongly recoumenedd we have a base images for each type of Mac. MacOS 10.12 is doing some new things with drivers and this is why. I wasn't the one on the call so I am getting this second hand.

Our work flow:
We use a base image that has minimal config, basic stuff like admin account and minimal settings. Apps and configuration to the default user are all done afterwards via scripts or the workflow tools.


Thoughts? Doesn't anyone else use 1 image for all their Macs or is it normal to keep images for each type?

Offline

#2 2017-02-16 00:35:07

lsadauskas85
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

I'm having the same issue as well. This was never an issue until 10.12. Also, suggesting that there be a different image for each type of Mac is incorrect. I took an image of a MBP Touch and restored that image directly back onto the machine it came from and had the same problem

Offline

#3 2017-02-16 00:47:02

s10010001
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

Not sure what a MBP Touch is but cool!

Doing some more reading it looks like using Thin images created with AutoDMG is the way to go here. I just need to automate the creation and possible customization of our local admin account with the password secured.

any ideas on this guys?

Offline

#4 2017-02-16 00:54:31

lsadauskas85
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

In our environment, using only a thick image is possible due to certain configurations, so any clues on how to continue down that path and avoiding this issue would be awesome.

Offline

#5 2017-02-16 00:55:35

lsadauskas85
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

Oh, and by MBP Touch I meant the new MacBook Pros with Touchbar

Offline

#6 2017-02-16 04:03:40

lsadauskas85
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

Using the "Restore" workflow, there's an option to delete the network configuration files. This seems to have fixed my issue pending more testing.

Using a thick image from an iMac to a MacBook Pro with Touch Bar

Offline

#7 2017-02-16 18:04:24

s10010001
Member
Registered: 2017-02-15

Re: Question about base images, problems with 10.12

Ill give that a try.. thanks! I got a thin image made with AutoDMG working and Createuser pkg to make out local account but yeah theres some settings I'm going to have to script in, or go back to thick imaging.

MBP Touch sounds awful!

Offline

Board footer

Powered by FluxBB