You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2016-12-14 21:45:06

dugnl
Member
Registered: 2016-12-14

admin assistant 1.6.17 fails to create USB device on new 2016 Macbook

We got a brand new 2016 macbook with the touch bar.   Our previously working USB boot drives into Deploy Studio returned a circle with a line through it.   Those drives work on all other Macbooks.

Our DeployStudio Server has 1.6.17.   Installing 1.6.17 on the new macbooks seems to work fine.  However, when using the admin assistant to create a USB drive, we immediately receive an error "the recovery partition doesn't match your boot system" and then when we select continue anyway, drive creation immediately fails with "creation failed"

On a 10.11.6 OS installation this works (older Mac).   But on the new touch bar MAC that came with OS 10.12.2 this fails.

Interestingly, I can install DeployStudio 1.7.5 on this new Macbook and get the USB drive created.   Whenever I plug that into the new MAC we get past the circle with a line on it but then end up with an error that the server is "not compatible".

Anyway to get this working besides upgrading our server to 1.7.5?     And if we do have to end up upgrading our server, will old thumb drives that have 1.6.17 still communicate with 1.7.5 server and work correctly for installs on Macbooks? (we don't want a compatibility issue as we have a lot of thumb drives floating around across our campus).   So we are hesitant to upgrade our server to see if that resolves the compatibility issue.

So, two issues here:  1.  How can we create a thumb drive on new touch bar 10.12.2 Macbooks using admin assistant 1.6.17?    If we can't and have to go to a different version, what about the compatibility issue upon boot?

Thank you,

Doug

Last edited by dugnl (2016-12-14 21:46:44)

Offline

#2 2016-12-17 00:02:17

Meat
Member
From: SF CA US
Registered: 2009-02-04

Re: admin assistant 1.6.17 fails to create USB device on new 2016 Macbook

Our previous DeployStudio Server installation was 1.7.3.
Trying to create a netboot set in that version presented a dialog box that said the OS version is unsupported.

I updated to DeployStudio Server 1.7.5 and it worked fine. (haven't tried capturing an image yet though...)
I tested the new netboot image with an older model laptop and it netbooted to the workflow selector as expected.

As the 1.7.3 version appears to know it can't support macOS 10.12.2 (at least on these touchbar models) I would suggest you are going to have to reach out to your thumbdrive holders and get them updated, as most certainly version 1.6.17 isn't going to support it either.

Offline

Board footer

Powered by FluxBB