You are not logged in.


[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2015-11-04 19:38:16

Registered: 2015-11-04

Deploystudio Assistant Service Unreachable

Hello everyone!

I have a El Capitan Server that I am trying to get setup as a secondary Deploystudio server. I have downloaded and installed DS 1.6.17 on to the thing, and updated my master to 1.6.17. But I whenever I use the Assistant to finish the setup I get an error message of:

The address 'http://<myDSserver>:60080' is not valid or the host is unreachable.
If you are using a web proxy, please bypass proxy settings for the DeployStudio server host.

The odd thing is I can actually connect to it in a web browser, from the local DS admin console and runtime (it complains about no repository being setup) as well as from the Assistant on my master. It's just the local Assistant that won't connect. I have tried using the IP, FQDN and just the hostname in the sever field with no luck. It's also worth noting that I cannot connect to my master via the assistant either.

So I am completely stumped, anyone got an idea on how I can fix this?

Thanks in advance

Last edited by jcoombes (2015-11-04 19:40:43)


#2 2015-11-05 01:41:42

Registered: 2015-11-05

Re: Deploystudio Assistant Service Unreachable

I'm having the same problem.

El Capitan running Deploy Studio 1.6.17. Everything except the DS Assistant (web, telnet, DS admin) seems to be able to connect fine but without being able to connect with the DS Assistant, I can't complete the initial set up.

I've tried using the DNS name, the IP address, localhost and connecting from DS Assistant running on another machine and all have failed with the error:

The address 'http://<myDSserver>:60080' is not valid or the host is unreachable.
If you are using a web proxy, please bypass proxy settings for the DeployStudio server host.

Firewall is disabled, proxy is off, logs don't show any connection attempts. Any help would be appreciated.

Edit: Just uninstalled 1.6.17 and installed 1.6.16 and was able to successfully connect. Possible bug?

Last edited by cholly (2015-11-05 02:14:10)


#3 2015-11-05 18:25:01

Registered: 2015-11-04

Re: Deploystudio Assistant Service Unreachable

I am almost certain that this is a bug.  I am going to downgrade from El Capitan to Yosemite and see if the problem persists (it's a brand new server with nothing setup on it, so blowing it away is not a big deal).

Another odd thing is that if I use the assistant on the master to connect to the master I get told that it can;t work since it's v17 and the master is V12 (the initial version I installed many moons ago). I have to turn the service off, and then back on again to get it to work (read the correct version?).

So I'd advise people to steer clear of 17 for now.

Anyone know how to file a bug report?

Last edited by jcoombes (2015-11-05 18:25:49)


#4 2015-11-05 18:35:15

From: SF CA US
Registered: 2009-02-04

Re: Deploystudio Assistant Service Unreachable

There is reportedly a workaround:

No corroborating reports of success yet, but...

I've been SSL for some time, since our network security team had flagged server HTTP connectivity as an issue, so this didn't effect my installs.

Last edited by Meat (2015-11-05 18:36:42)


#5 2015-11-09 23:29:54

Registered: 2007-03-29

Re: Deploystudio Assistant Service Unreachable

Hi, it should work better with 1.6.18.


#6 2016-03-17 16:29:07

Registered: 2016-03-17

Re: Deploystudio Assistant Service Unreachable

I received this error after updating my server to 1.7.2 from 1.6.15.

After the upgrade I couldn't configure the server with Assistant. Kept saying the service was unreachable.

Turned out it worked OK if I switched from SSL to non-SSL by changing https:// to http://,
however I *wanted* SSL, so, it turned out the real solution was this:

1. Uninstall DS Server & install 1.6.18. Don't worry, your repository and all its masters/packages/workflows will stay untouched.
2. Enter appropriate server address/login info and point it at your repository. You will have to respecify most of your server configuration including: address, username/passwords, address to repository, access groups for admin/assistant/runtime.
3. After I confirmed that SSL was working and I could access DS through Admin remotely, then I upgraded to 1.7.2.
4. After this I had to run Assistant again and respecify the address of the network repository, but the other information stayed intact.
5. Other post-upgrade stuff like updating netboots has to be done, but is off-topic.


Board footer

Powered by FluxBB