You are not logged in.

Announcement

[2017.09.08] DeployStudio build v1.7.8 (checksum, release note).
[2016.08.26] DeployStudio build v1.6.19 (release note).
[2013.02.23] DeployStudio last universal build v1.5.17 (release note).

#1 2015-09-17 21:58:10

macthek9
Member
Registered: 2011-03-01

Repository access error DS 1.6.16

Running DS 1.6.16 with a 10104 NBS.  I am hosting DS 1.6.16 on a MAC OS 10.10.4 server...  Whenever I boot a client, ! get a repository access error...  Error while mounting the share...  Not sure what I am doing wrong, as I have opened it up to full access, so can't imagine its a access control issue...  Log reports success all the way up to the mount call....  "mount_afp: The Mount point tmp/DSNetworkRepository does not exist, realpath returns 2" etc, then "parsed key cannot be nil" then "mount failed cleaning local mount point"   

Please advise on a potential resolution. 

Thanks to all who may contribute!

Offline

#2 2015-09-18 22:02:00

Nathan Fisher
Member
Registered: 2014-08-13

Re: Repository access error DS 1.6.16

can you paste the actual log, there may be some additional details we need to see

in the meanwhile:
- login to another client computer and try to connect to the repository USING THE EXACT INFORMATION you have configured on the server
- if it will let you stop the netboot and open a terminal window, see if you get an error with the command:   mkdir /tmp/testfolder

Offline

#3 2015-10-01 17:34:59

macthek9
Member
Registered: 2011-03-01

Re: Repository access error DS 1.6.16

Here is the log... 

2015-10-01 11:41:06.620 DeployStudio Runtime.bin[391:5201] ====================================================================================================
2015-10-01 11:41:06.620 DeployStudio Runtime.bin[391:5201] DeployStudio Runtime
2015-10-01 11:41:06.646 DeployStudio Runtime.bin[391:5201] DSCore.framework version 1.6.16 (b150725), Copyright 2015 The DeployStudio Team.
2015-10-01 11:41:06.659 DeployStudio Runtime.bin[391:5201] MAC address: c8:2a:14:4e:46:60
2015-10-01 11:41:06.671 DeployStudio Runtime.bin[391:5201] Network address: 10.3.4.52 (p-2001-mac.ushmm.org)
2015-10-01 11:41:06.713 DeployStudio Runtime.bin[391:5201] Network interface speed: AUTOSELECT (100BASETX <FULL-DUPLEX,FLOW-CONTROL>)
2015-10-01 11:41:06.773 DeployStudio Runtime.bin[391:5201] Operating System: Mac OS X Version 10.10.4 (Build 14E46)
2015-10-01 11:41:06.773 DeployStudio Runtime.bin[391:5201] Date: 15/10/01 11:41:06
2015-10-01 11:41:06.773 DeployStudio Runtime.bin[391:5201] ====================================================================================================
2015-10-01 11:41:07.973 DeployStudio Runtime.bin[391:5201] 24 plugins were successfully loaded!
2015-10-01 11:41:12.276 DeployStudio Runtime.bin[391:17629] The user 'sysop' was successfully authenticated.
2015-10-01 11:41:12.333 DeployStudio Runtime.bin[391:5201] Connected to server sanman.local (1.6.16)
2015-10-01 11:41:12.555 DeployStudio Runtime.bin[391:17629] Checking server reachability (server=(null) port=7) ...
2015-10-01 11:41:12.555 DeployStudio Runtime.bin[391:17629] Mounting repository share point...
2015-10-01 11:41:12.556 DeployStudio Runtime.bin[391:17629] Mount call...
2015-10-01 11:41:12.630 DeployStudio Runtime.bin[391:17629] mount_afp: The mountpoint: /tmp/DSNetworkRepository does not exist, realpath returns 2
2015-10-01 11:41:12.630 DeployStudio Runtime.bin[391:17629] Parsing result...
2015-10-01 11:41:12.630 DeployStudio Runtime.bin[391:17629] The parsed key cannot be nil!
2015-10-01 11:41:12.630 DeployStudio Runtime.bin[391:17629] Mount failed cleaning local mount point...

Offline

#4 2015-10-01 22:06:28

macthek9
Member
Registered: 2011-03-01

Re: Repository access error DS 1.6.16

This is resolved.  Recovery Partition mismatch.
 
Terminal.... 

chmod +x ~/Downloads/recovery.sh
sudo ~/Downloads/recovery.sh

Then created new NBS-10105.

Offline

Board footer

Powered by FluxBB